Nagios Xl — Understanding The User Macros

Component

The Industry Standard in IT Infrastructure Monitoring

Purpose

This document describes how to use the User Macros component in Nagios XI. The component exposes the user and system macros
available in Nagios Core to multiple areas of Nagios XI, allowing for more flexible configurations.

Target Audience

This document is intended for use by Nagios XI Administrators who want to take advantage of user and system macros in Nagios XI.

What Is A Macro ?
One of the main features that make Nagios so flexible is the ability to use macros in object definitions. If you are familiar with
programming languages, a macro is just like a variable:

® Avalue is assigned to a macro

® The macro is used in object definitions

® If you update the macro, all the object definitions use the updated value in the macro

There are two types of macros in Nagios Xl, user macros and system macros.

What Does The User Macros Component Do ?

The primary purpose of the User Macros component is to make the $ARGLS

user and system macros available for use when using Configuration

$HOSTADDRESSS
Wizards or when editing objects in Core Configuration Manager $ARGZS $HOSTSTATES
(CCM). $TIMET$
$ARG3S
SUSER1S
An auto-complete list will appear when you start typing with a $ sARG4s | FUSERVS
(dollar) character, see the screenshot to the right. $LSERBS
$ARGSS

In the example shown to the right, a combination of user and

system macros is shown. A more detailed explanation of user and system macros will be explained next.

The User Macros component allows you to edit the existing user macros and also add new macros. This functionality is performed in

CCM and will be explained in this documentation.
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User Macros
User macros are macros that can be defined by the Nagios XI administrator. They are stored by default in the resource.cfqg file

which is located in the /usr/local/nagios/etc/ directory.

The syntax to define a macro in this file is:
SUSERnS$=x

n = a number between 1-256 (you cannot have the same number defined more than once, the first defined macro will always take
precedence)

x = the value of the macro, no space after the '=' character

The resource.cfg file will have default macros defined in it already such as SUSER1$=/usr/local/nagios/libexec and these
should not be edited or removed without knowing the full consequences - this can break the core processes from running checks and
could be a real headache.

The SUSER1$ macro is a great example of how a macro is used in a command definition, take a look at this command definition:
SUSER1$/check_http -H $HOSTADDRESSS
Instead of typing /usr/local/nagios/libexec all you need to type is SUSER1S in the command definition.

The maximum number of macros by default is 256. You can change this through configuration if you need more macros than the

default (Note: the max number is a Nagios Core setting).

A feature of the User Macros component is the ability to update the resource. cfg file from within CCM, instead of having to edit the

file from a terminal session, which will be explained in this documentation.

System Macros

System macros are macros that cannot be defined by the Nagios XI administrator, their values are inherited from object definitions and

can also be dynamic. Some examples are:

® SHOSTADDRESSS = The value of the address directive in a host definition
® S$ARG1S = The value of argument #1 in a host or service definition

® SHOSTSTATES = The current state of the HOST object, this dynamic macro is commonly used in a notification command

These macros are useful in a number of ways and are explained in detail here:

https://assets.nagios.com/downloads/nagioscore/docs/nagioscore/4/en/macrolist.html
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A feature of the User Macros component is the ability to define which of these system macros will be made available in areas like CCM

and Configuration Wizards, which will be explained in this documentation.

Configuring User Macros Component

Login to Nagios XI and navigate to Admin > System Extensions > Manage Components.

Home Views Dashboards Reports Configure Tools Help Admin ¥ & nagiosadmin & Logout
S T Scheduled Backups &
A Users Provides the ability to schedule full Nagios XI backups. Core = 1.1.3

A System Config % 1.1.3 ™ 09/15/2016 & Nagios Enterprises, LLC

A Monitoring Config Scheduled Reporting @
Adds scheduled reporting capability to Nagios XI. Core 7 2.2.0
% 2.2.0 06/22/2016 & Nagios Enterprises, LLC

~ Check Transfers
w System Extensions

&) Manage Companents System Profile

# Manage Contig Wizards, This component creates a system profile menu in the Admin panel which can be used for troubleshooting purposes. Core # 1.3
M ane Pesiiets ®1.3.1 #05/25/2016 & Nagios Enterprises, LLC

& Manage Plugins

Manage Graph Templates User Macros

Manage MIBs

B Custom Includes Manage user and system macros. Core . 1.0.1

% 1.0.1 & Nagios Enterprises, LLC
A System Backups

Click the Edit Settings icon to configure the User Macros component, which will display the settings available for the component as

follows:
User Macros (7]
Detect, create, display and define system and user macros in Magios XI.
This component will detect input of '$USERN%' user defined macros where 'n' is a number between 1 and 256. This number is defined in Nagios Core as
MAX_USER_MACROS. It will also give a user a list of commonly used System Macros in the appropriate inputs. The system marcos are displayed using
autocomplete and the full list of available macros are defined in the System Macros tab.
MNote: To manually enable detection fucntionality on a page inside Magios XI or a custom compenent/tool you can add the class "usermacro-detection” te an HTML input.
% User Macro Contral (CCM)
Te view the macro files go the the User Macro section in the CCM by clicking this link.
Component Settings
These are the general settings for this component.
[[] Disable Component
@ Redact Displayed Values (Enabled by Default)
This opticn will redact the USER macro values from being displayed to protect sensitive data for ALL users. With this opticn enabled you will still be able to add
undefined macros when they are detected. This will override the Nen-Admin user setting.
Apply Settings Cancel
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Disable Component:
This will turn off all detection of macros and the User Macro link in the CCM will not be available. This option is specifically useful if you

need to vet the component or have security concerns with the content of your resources file where User macros are stored.

Redact Values:
User Macros often contain sensitive data such as passwords or tokens. They are also useful for using restricted characters that are
normally not allowed for use in certain commands (example: Nagios Core interpreting a "!' character in a command). Since the

information they hold can be sensitive, there are two options for obscuring the values of the macros:

Redact Displayed Values:
This will redact USER macro values from being displayed anywhere. Here is an example:

$ARG1S | SUSERBS $ $USERBG=*****

When you hover the mouse over the $ box a message box will display the value with asterisk's.

When Redact Displayed Values is enabled, you can create a new User macro while using the detection in CCM and
in Configuration wizards (explained in detail further on in this document). However you will not be able to directly edit
the User macros via CCM > Tools > User Macros.

In a fresh Nagios Xl install this will be turned on by default (enabled).

If you turn off (disable) this option all users will be able to see the macro values, for example:

$ARG1$  $USERS% S $UUSERSES

Redact Displayed values for Non-Admin Users:
This feature works exactly like the default redact function, but is specifically designed to always show macro values to
Admin level users and hide values from all non-admin users. This option can only be enabled when the Redact

Displayed Values option is disabled.

Here is an example of what an Admin user will see:

$ARG1E | $USERSS S $UUSERG%=secret
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Here is an example on what a NON-Admin user will see:

w Configuration Wizard: Windows Server - Step 2 EIERE $USER

This should be considered when giving admin rights to users since those users will be able to see all user macro
values. This is similar to a user who has login access to the Nagios XI machine since they could just read the

resource.cfg file from the command line.

Edit User Macros

Login to Nagios XI and navigate to Configure > Core Configuration Manager > Tools > User Macros.

Nagios Home Views Dashboards Reports Help Admin Q @ &nagiosadmin @ Logout =

CLIN Core Config Manager

» Quick Tools

User Macros Component

Click here to configure the User Macro component %
A Monitoring

Component Settings: Component Enabled B Redact Displayed Values
A Alerting

A Templates User Macros System Macros

A Commands . .
You can view and edit the assigned User Macros for your system here.

» Advanced
Note: If you edit this file it will overwrite the original content so you will not be able to undo any changes. If Redact Displayed Values is enabled you will not be able to edit the file.
w Tools
[ Static Config Editor fusr/local /nagios/etc/resource.cfg ®©
@ Esca al\on Wizard # Path to the plugins

22 Bulk Modifications Tool $USER1%=/usr/local/nagios/libexec

W Bulk Renaming Tool # Path to event handlers
& Import Config Files #$USER2$=/usr/local/nagios/libexec/eventhandlers

I Config File Management # Port for NSClient++
$USER7$=12489
# Password for NSClient++
SR $USERBS =secret

The User Macros tab is the default tab selected. The User Macros section will appear differently depending on how the User Macros
component is configured.
Redact Displayed Values option is Enabled:
All of the values will be redacted and will appear with *****
You cannot edit existing values or add new values
The Update button is NOT displayed

Redact Displayed Values option is Disabled:
All of the values will be shown
You can edit existing values and add new values
The Update button is displayed

The screenshot above is an example of this.
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Updating an existing macro or adding a new macro is as easy as adding a new line. For example:
SUSER10$=!ts@S3cr3t

Click the Update button once you've made the changes.

Please refer to the User Macros section on page 2 of this document for the correct syntax.

After making changes, Nagios Core will need to be restarted so that the updated values are loaded from the resource.cfgfile. This

can be done via CCM > Tools > Config File Management > Restart Nagios Core.

System Macros

Login to Nagios XI and navigate to Configure > Core Configuration Manager > Tools > User Macros and then click the System

Macros tab.

Na glos Home Views Dashboards Reports Help Admin Q @ &nagiosadmin ) Logout =

CLIN Core Config Manager

A Quick Tools

User Macros Component

Click here to configure the User Macro component -
~ Monitoring

Component Settings: Component Enabled B Redact Displayed Values
» Alerting

+ Templates User Macros System Macros

.- Here you can add and remove System Macros that will be displayed as a selection option when a macro is detected.

o Aume For general information about usage and which macros are supported check the Nagios Core documentation here. Double click to add and remove or select multiple and click the
w Tools add/remove buttons.
¥ Static Config Editor
(,m iler Active Detected System Macros
rd Host ] $HOSTADDRESSS
= x -
S e
$HOSTDISPLAYNAMES $TIMETS
& Import Config Files $HOSTALIASS
I Config File Management $HOSTADDRESSS
$HOSTSTATES n
A CCM Admin $HOSTSTATEIDS
$LASTHOSTSTATES ] n
SLASTHOSTSTATEIDS
$HOSTSTATETYPES
$HOSTATTEMPTS
$MAXHOSTATTEMFTSS

Update

The purpose of the System Macros tab is to be able to select specific macros that you would like to be displayed when the auto-
complete list appears.

In the above screenshot you can see that three macros were added to the Active Detected System Macros.
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In the screenshot to the right you can see that these three macros ¥ ¥
are made available in the auto-complete list: $ARG2S $HOSTADDRESSS
$HOSTSTATES
P $TIMETS
$USER1S
sARGas | SUSER7S
$USERBS
$ARGSS$

It's important to note that adding system macros to the Active Detected System Macros list is purely to make it easy to select a
system macro from the auto-complete list. All system macros will work in any configuration area of Nagios Xl regardless if they are in

this list or not.

Creating New User Macros On The Fly

In the Edit User Macros section of this document you were shown how to add a new macro. Another feature of the User Macros
component is the ability to create a new User macro when you are in the middle of running a configuration wizard OR editing an object

in CCM. Here's how it works when you are in CCM.

First you start off by typing $U to make the auto-complete
Irstyou y typing $ u p $ARG1S

list appear. You can see in the screenshot to the right that

SUSER1S, SUSER7S$ and $SUSER8S already exist. $ARG2S SUSER1%
$USERTS

USERS
This example is going to add $USER11$ as it does not SARG3% * i
exist.

Simply finish typing the name of the user Macro
and as soon as you type the closing $ a blue $ $ARGLS $U5ER11$|

button will appear to the right.

When you hover your mouse over the blue $ button a message window will appear

informing you that the macro is undefined and to click it to set a value.
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Click the blue $ button and the Create New

User Macro window will appear.

Type a value in the field at the bottom of the
window and then click the Save Macro

button.

You will receive a success message once the

new macro has been added.

Click the Close button when done.

NOTE: The new macro will not be active until
Nagios Core is restarted. This will occur
when you Apply Configuration OR you finish
a Configuration Wizard.

The ability to add new user macros will be
available as long as the User Macros

component is enabled, see the Configuring

Create New User Macro

fusrflocal fnagios fetc/resource.cfg

# Path to the plugins
SUSER1G=****=*

# Path to event handlers
#FUSER2§=*****

# Port for NSClient++
SUSERT7G=**xx%x

# Password for NSClient++
SUSERBG=****=*

New Macro = $USER11$ ‘ Csup3rs3crat ) | Close

User Macros Component section for more information on this.

Finishing Up

This completes the documentation on the User Macros component. If you have additional support related questions please visit us at

the Nagios Support Forums:

https://support.nagios.com/forum
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