Docker Error – Requires: container-selinux >= 2:2.74

Error\

$ sudo yum install -y docker-ce
--> Finished Dependency Resolution
Error: Package: 3:docker-ce-19.03.5-3.el7.x86_64 (docker-ce-stable)
           Requires: container-selinux >= 2:2.74
           Installed: 2:container-selinux-2.9-4.el7.noarch (@/container-selinux-2.9-4.el7.noarch)
               container-selinux = 2:2.9-4.el7
Error: Package: containerd.io-1.2.10-3.2.el7.x86_64 (docker-ce-stable)
           Requires: container-selinux >= 2:2.74
           Installed: 2:container-selinux-2.9-4.el7.noarch (@/container-selinux-2.9-4.el7.noarch)
               container-selinux = 2:2.9-4.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Solution

  • Go to http://mirror.centos.org/centos/7/extras/x86_64/Packages/
  • Find the latest version for container-selinux i.e. container-selinux-2.21-1.el7.noarch.rpm
  • Run the following command on your terminal: $ sudo yum install -y yum install http://mirror.centos.org/centos/7/extras/x86_64/Packages/container-selinux-2.107-1.el7_6.noarch.rpm
  • yum install docker-ce
Rajesh Kumar