Hi geeks, yesterday i tried to run a command in my laravel project ver 5.8 then it’s showing two issue in my git bash. my php version in composer.json file is “^7.1.3”.
Problem 1 - Root composer.json requires php ^7.1.3 but your php version (8.0.0) does not satisfy that requirement. Problem 2 - laravel/framework[v5.8.0, ..., 5.8.x-dev] require php ^7.1.3 -> your php version (8.0.0) does not satisfy that requirement. - Root composer.json requires laravel/framework 5.8.* -> satisfiable by laravel/framework[v5.8.0, ..., 5.8.x-dev].
whenever you find these type of issue then try below command to solve the issue: if sometimes your issue will not resolve by below command then please comment us for more solution on this type of issue.
composer install --ignore-platform-reqs
For more understanding on these issues please read below references:
- How to Fix ” Vue packages version mismatch:” error in Laravel 5.5 - April 15, 2021
- Laravel say that Auth guard [user] is not defined - April 15, 2021
- Laravel 5.5 Error – “The page has expired due to inactivity. Please refresh and try again.” - April 9, 2021