Eloquent-sluggable in laravel Installation failed? (Solution)

  • Conclusion: don’t install laravel/framework v5.7.9
    • cviebrock/eloquent-sluggable 4.8.x-dev requires illuminate/config ~5.8.0 -> satisfiable by illuminate/config[5.8.x-dev

Solution:-

Depending on your version of Laravel, you should install a different version of the package. NOTE: As of version 6.0, the package’s version should match the Laravel version. Older versions of Laravel can use older versions of the package, although they are no longer supported or maintained.

Laravel VersionPackage Version
6.06.0.*
5.84.8.*
5.74.6.*
5.64.5.*
5.54.3.*
5.44.2.*

Try:- composer require cviebrock/eloquent-sluggable:3.0.0-alpha

Try:- composer require cviebrock/eloquent-sluggable:3.0.*